Android教程網
  1. 首頁
  2. Android 技術
  3. Android 手機
  4. Android 系統教程
  5. Android 游戲
 Android教程網 >> Android技術 >> 關於Android編程 >> HDU 2040 親和數

HDU 2040 親和數

編輯:關於Android編程


古希臘數學家畢達哥拉斯在自然數研究中發現,220的所有真約數(即不是自身的約數)之和為:

1+2+4+5+10+11+20+22+44+55+110=284。

而284的所有真約數為1、2、4、71、 142,加起來恰好為220。人們對這樣的數感到很驚奇,並稱之為親和數。一般地講,如果兩個數中任何一個數都是另一個數的真約數之和,則這兩個數就是親和數。

你的任務就編寫一個程序,判斷給定的兩個數是否是親和數
 


Input
輸入數據第一行包含一個數M,接下有M行,每行一個實例,包含兩個整數A,B; 其中 0 <= A,B <= 600000 ;
 


Output
對於每個測試實例,如果A和B是親和數的話輸出YES,否則輸出NO。
 


Sample Input
2
220 284
100 200


Sample Output
YES
NO
 

import java.io.BufferedInputStream; 
import java.util.*; 
public class Main { 
    public static void main(String[] args) { 
        Scanner sc=new Scanner(new BufferedInputStream(System.in)); 
        int k,m,n; 
        k=sc.nextInt(); 
        for(int i=0;i<k;i++) 
        { 
            m=sc.nextInt(); 
            n=sc.nextInt(); 
            fun(m,n); 
        } 
    } 
    public static void fun(int m,int n) 
    { 
        int sum1=0; 
        int max=Math.max(m, n); 
        int min=Math.min(m, n); 
        for(int i=1;i<max;i++) 
        { 
            if(max%i==0){ 
                 
                sum1+=i; 
            } 
        } 
        if(sum1==min)  
            System.out.println("YES"); 
        else  
            System.out.println("NO"); 
    } 
} 

import java.io.BufferedInputStream;
import java.util.*;
public class Main {
 public static void main(String[] args) {
  Scanner sc=new Scanner(new BufferedInputStream(System.in));
  int k,m,n;
  k=sc.nextInt();
  for(int i=0;i<k;i++)
  {
   m=sc.nextInt();
   n=sc.nextInt();
   fun(m,n);
  }
 }
 public static void fun(int m,int n)
 {
  int sum1=0;
  int max=Math.max(m, n);
  int min=Math.min(m, n);
  for(int i=1;i<max;i++)
  {
   if(max%i==0){
    
    sum1+=i;
   }
  }
  if(sum1==min)
   System.out.println("YES");
  else
   System.out.println("NO");
 }
}

 

 

  1. 上一頁:
  2. 下一頁:
熱門文章
閱讀排行版
Copyright © Android教程網 All Rights Reserved